Document downloads/request failures

Incident Report for BlacksmithKYC

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 08:04 UTC

Investigating

Some users are currently experiencing issues with requesting and sending documents, our engineering team is investigating this issue and we will update you in due course.
Posted Jun 30, 2026 - 13:37 UTC
This incident affected: BlacksmithKYC.