Blacksmith Search failures

Incident Report for BlacksmithKYC

Resolved

This incident has been resolved.
Posted Sep 07, 2026 - 08:31 UTC

Investigating

Some Blacksmith users are currently experiencing failures when running searches. We are aware of the issue and working on it urgently. We will provide an update as soon as it is available
Posted Sep 07, 2026 - 08:15 UTC
This incident affected: BlacksmithKYC.