Login Issue

Incident Report for BlacksmithKYC

Monitoring

The system is now available and we are continuing to monitor. We will confirm once the full fix has been deployed and this incident is fully resolved. Please contact support if you require any assistance.
Posted Mar 10, 2026 - 12:14 UTC

Identified

The Blacksmith system is currently unavailable. We are working on an immediate fix as well as a full fix which will soon be available. We will provide an update as soon as possible.
Posted Mar 10, 2026 - 12:04 UTC

Monitoring

We have applied a fix and are monitoring the system. All users should now be able to log in. Please contact Support if you require assistance.
Posted Mar 03, 2026 - 10:07 UTC

Investigating

We are aware some users are unable to log in to Blacksmith, we are investigating now as a priority.
Posted Mar 03, 2026 - 10:00 UTC

Monitoring

All users should now be able to log into Blacksmith. We will monitor the system for stability throughout the day, please contact Support if you require any assistance.
Posted Mar 02, 2026 - 08:57 UTC

Investigating

Some users are currently unable to log in to the Blacksmith platform. We are aware of the issue and our engineering team are investigating as a priority. We will provide an update in due course.
Posted Mar 02, 2026 - 08:32 UTC
This incident affects: BlacksmithKYC.